$re = '/(?:\d{1,2},)?\d{1,3}\.\d{2}/m';
$str = '0.01
99.34
4,234.01
1,234
23.0
99,999.99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);