// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d{1,2},)?\d{1,3}\.\d{2}").unwrap();
let string = "0.01
99.34
4,234.01
1,234
23.0
99,999.99
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}