package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\W_]+|[^\w\s]|_`)
var str = `This is a-weird string,right?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}