# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(\s*\d+\s\).*?(?:^$|- - - -)"
test_str = ("( 2 )\n"
"01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ \n"
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n\n"
"( 3 )\n"
"01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ \n"
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
"ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n"
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ\n"
"ФФФФФФФФФФФФФФФ\n"
"ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
"ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n\n"
"( 4 )\n"
"08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ \n"
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
"ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n"
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ\n"
"ФФФФФФФФФФФФФФФ\n"
"ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
"ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
"Срок: ССССССССССССССССССССССССССССССССССССС\n"
"СССССССССССССССССССССССССССС\n"
"22.12.2014 - ННННННННННННННН : НННННННННННННННН \n"
"НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ \n"
"ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ\n\n"
"( 5 )\n"
"03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
"ууууууууууууууууууууу Срок: КККККККККККККККККККККК\n"
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ\n"
"- - - -")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.