import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<jobRunTimeMs1>\\d+)ms|(?<jobRunTimeS2>\\d+)s(?<jobRunTimeMs2>\\d+)ms|(?<jobRunTimeM3>\\d+)m(?<jobRunTimeS3>\\d+)s(?<jobRunTimeMs3>\\d+)ms";
final String string = "709ms\n"
+ "59s709ms\n"
+ "1m59s709ms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}