re = /(?<jobRunTimeMs1>\d+)ms|(?<jobRunTimeS2>\d+)s(?<jobRunTimeMs2>\d+)ms|(?<jobRunTimeM3>\d+)m(?<jobRunTimeS3>\d+)s(?<jobRunTimeMs3>\d+)ms/m
str = '709ms
59s709ms
1m59s709ms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end