#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))"
Local $sString = "But seeing them playing to seven- and eight-year-olds is beautiful" & @CRLF & _
"The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous"
Local $sSubst = "\2\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)