package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))`)
var str = `But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous`
var substitution = "\2\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}