// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))").unwrap();
let string = "But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous";
let substitution = "\\2\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}