using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(\[(((?<=\[)..*:|(?<=\[).))(.*)\])";
string substitution = @"$4";
string input = @"asdf[d4:asdf]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}