# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((<style>)|(<style type=.+)|(<\\/style>))//g;t' <<< "<style>
styles
</style>
<style type=\"text/css\">
styles
</style>"