#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((<style>)|(<style type=.+)|(<\/style>))"
Local $sString = "<style>" & @CRLF & _
" styles" & @CRLF & _
"</style>" & @CRLF & _
"" & @CRLF & _
"<style type="text/css">" & @CRLF & _
" styles" & @CRLF & _
"</style>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)