using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<style>)|(<style type=.+)|(<\/style>))";
string substitution = @"";
string input = @"<style>
styles
</style>
<style type=""text/css"">
styles
</style>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}