package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((<style>)|(<style type=.+)|(<\/style>))`)
var str = `<style>
styles
</style>
<style type="text/css">
styles
</style>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}