$re = '/((<style>)|(<style type=.+)|(<\/style>))/';
$str = '<style>
styles
</style>
<style type="text/css">
styles
</style>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;