$re = '/\p{Han}|[^а-яa-zА-ЯA-Z]+$/';
$str = '你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
S1f你好jd
S1f 你好jd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);