-----BEGIN the literal text -----BEGIN (case sensitive) .*any character, repeated any number of times
PRIVATE KEY-----the literal text PRIVATE KEY----- (case sensitive) .*?any character, repeated any number of times
-----END the literal text -----END (case sensitive) .*any character, repeated any number of times
PRIVATE KEY-----the literal text PRIVATE KEY----- (case sensitive)