# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d\.){2,}"
test_str = ("3.2.4.2. porta pellentesque \n"
"139. Nunc maximus maximus aliquet? \n"
" a) dignissim \n"
" b) volutpat \n"
" c) ullamcorper \n\n"
"3.2.4.3. ligula at condimentum fringilla \n"
"152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula? \n"
" a) vestibulum \n"
" b) pellentesque \n"
" c) tempus \n"
" d) rutrum \n"
" \n"
"153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis? \n"
" a) suscipit \n"
" b) vulputate \n"
" c) vestibulum \n"
" d) congue \n"
" \n"
"3.2.5. elementum quis \n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.