# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"to=<(?P<email>\S+)>,\srelay=(?!10\.10\.10\.)(?P<relay>\S+),.+dsn=(?P<dsn>\d+\.\d+\.\d+),\sstatus=(?!sent)(?P<status>\w)\w+\s\((?:host\s\S+\[\S+\]\ssaid:\s)?(?P<code>\d{3})? "
test_str = ("2016-10-17T00:00:00.028777+03:00 postfix/smtp[6628]: 878A13DCA5: to=<govorok@gmail.com>, relay=gmail-smtp-in.l.google.com[173.194.220.27]:25, delay=0.47, delays=0.01/0/0.12/0.35, dsn=2.0.0, status=sent (250 2.0.0 OK 1476651600 79si16679285lja.36 - gsmtp)\n"
"2016-10-17T00:00:00.029273+03:00 postfix/qmgr[4674]: 878A13DCA5: removed\n"
"2016-10-17T00:00:00.037122+03:00 postfix/smtpd[6697]: 0906DA5: client=unknown[192.168.2.74]\n"
"2016-10-17T00:00:00.039621+03:00 postfix/cleanup[6713]: 0906DA5: message-id=<20161016210000.0906DA5@mrelay-h3.hh.ru>\n"
"2016-10-17T00:00:00.040403+03:00 postfix/smtp[6690]: C5670B9: to=<daler_rajabov@inbox.ru>, relay=mxs.mail.ru[217.69.139.150]:25, delay=0.23, delays=0.01/0/0.02/0.2, dsn=2.0.0, status=1s3ent (250 OK id=1bvsXH-0003Cb-Rp)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.