$re = '/([0-9]).(.+)[^+\d]([0-9]+)/m';
$str = '1.54.017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);