$re = '/[.,](\d{2})(?!\d)/';
$str = '$123,456.78
123,456.78 dollars
123,456.78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);