import Foundation
let pattern = #"The following dependencies in Dependencies have newer versions:\s+([^:]+:[^: ]+).*?([0-9]+(?:.[0-9]+)+) -> ([0-9]+(?:.[0-9]+)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The following dependencies in Dependencies have newer versions:
org.apache.maven:maven-plugin-api ..................... 3.6.0 -> 3.6.1
org.apache.maven.plugin-tools:maven-plugin-annotations ...
3.5.2 -> 3.6.0
org.codehaus.groovy:groovy-all ................. 2.5.7 -> 3.0.0-beta-2
Project does not have a parent.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)