$re = '/(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)/m';
$str = 'Слово2 и Слово1.
Слово1 и Слово2.
Слово1.
Слово2, а также слово1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);