import re
regex = re.compile(r"(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)", flags=re.MULTILINE)
test_str = ("Слово2 и Слово1.\n"
"Слово1 и Слово2.\n"
"Слово1.\n"
"Слово2, а также слово1.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")