use strict;
my $str = '# Match any(配對任何)
#下方為測試文字區塊
AE-403.jpg
BK-201.BMP
Qb-666.acg
AZ-404.qoo
ae-103.png
BK-201.svg
qb-666.ai
az-404.ai.tmp
#解釋:藍色部分就是透過規則/\\.a../所配對成功的文字,這裡是說幫我先配對 .(dot),再來配對 a,最後才是任何。\\. 代表使用這個特殊字元的原始用法
';
my $regex = qr/\.a../mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}