$re = '/https?/m';
$str = '# Quantifier:?篇
#下方為測試文字區塊
http://www.kcg.gov.tw/Default.aspx
https://www.google.com.tw/
http://www.gov.taipei/
https://www.youtube.com/?gl=TW
https://www.netflix.com/tw/
#解釋:藍色部分就是透 過規則/https?/所配對成功的文字,這裡判斷說http後,如果有 s 代表配對成功,沒有 s 也可以判斷成功。';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);