// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d*\.a..").unwrap();
let string = "# Quantifier:* 篇
#下方為測試文字區塊
AE-403.jpg
BK-201.BMP
Qb-666.acg
AZ-404.qoo
ae-103.png
BK-201.svg
qb-666.ai
az-404.ai.tmp
qK-.ajpg
#解釋:藍色部分就是透過規則/\\d+\\.a../所配對成功的文字。
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}