re = /(bra){3}/m
str = '# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算 配對成功。
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end