import Foundation
let pattern = #"(bra){3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)