$re = '/(?:(?!\/)).*(?:\/)(.[A-Z0-9]*[-][0-9]*)/m';
$str = '"Currently WV Patients are having difficulty reading some of the information on Key pages like product pages/shipping information etc. this story is to fix some of the font colors/size etc for better user experience. UP9-9999\\n\\n
[https://our-domain.atlassian.net/browse/UP-7930#icft=UP-7930|https://our-domain.atlassian.net/browse/UP-7930#icft=UP-7930] \\n\\n
[https://our-domain.atlassian.net/browse/UP-6744#icft=UP-6744|https://our-domain.atlassian.net/browse/UP1-6744#icft=UP-6744]\\n\\n
and\\n\\n\\
[https://our-domain.atlassian.net/browse/UP-6396|https://emersonecologics.atlassian.net/browse/UP-6396] \\n\\n
end more\\n\\n
[https://our-domain.net/browse/UP-5746|https://emersonecologics.atlassian.net/browse/UP2-5746]\\n\\n
test 2",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);