#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Mikołaj"
Local $sString = "W kościelnej liturgii oraz w zwyczajach ludowych Boże Narodzenie poprzedzone jest okresem trzytygodniowego oczekiwania (dokładnie czterech niedziel), zwanego adwentem. W tym okresie wierni biorą udział w roratach poświęconych Najświętszej Marii Pannie. Dawniej w niektórych regionach Polski wyplatało się także wieńce adwentowe, które w pierwszą niedzielę adwentu wieszało się w domu pod sufitem i zapalało na nim świeczkę. W każdą następną niedzielę dokładano kolejne świeczki. Tradycją stało się również pieczenie bożonarodzeniowych pierników, wykonywanie ozdób na choinkę oraz wysyłanie kart świątecznych z życzeniami do krewnych i znajomych. W okresie adwentowym 6 grudnia przypada dzień św. Mikołaja, kiedy to dzieci obdarowywane są drobnymi prezentami, wkładanymi do butów lub pod poduszki." & @CRLF & _
"" & @CRLF & _
"Przez cały adwent aż do Święta Trzech Króli (6 stycznia) w niektórych regionach Polski po wsiach chodzą „gwiazdorzy”, którzy śpiewają kolędy, recytują wiersze albo wystawiają herody inspirowane jasełkami[1]. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")