using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Mikołaj";
string input = @"W kościelnej liturgii oraz w zwyczajach ludowych Boże Narodzenie poprzedzone jest okresem trzytygodniowego oczekiwania (dokładnie czterech niedziel), zwanego adwentem. W tym okresie wierni biorą udział w roratach poświęconych Najświętszej Marii Pannie. Dawniej w niektórych regionach Polski wyplatało się także wieńce adwentowe, które w pierwszą niedzielę adwentu wieszało się w domu pod sufitem i zapalało na nim świeczkę. W każdą następną niedzielę dokładano kolejne świeczki. Tradycją stało się również pieczenie bożonarodzeniowych pierników, wykonywanie ozdób na choinkę oraz wysyłanie kart świątecznych z życzeniami do krewnych i znajomych. W okresie adwentowym 6 grudnia przypada dzień św. Mikołaja, kiedy to dzieci obdarowywane są drobnymi prezentami, wkładanymi do butów lub pod poduszki.
Przez cały adwent aż do Święta Trzech Króli (6 stycznia) w niektórych regionach Polski po wsiach chodzą „gwiazdorzy”, którzy śpiewają kolędy, recytują wiersze albo wystawiają herody inspirowane jasełkami[1]. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}