# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"steps\":)[^,]+"
test_str = "{\"summaryId\":\"x436a218-61703d00-15180-6\",\"calendarDate\":\"2021-10-21\",\"activityType\":\"WALKING\",\"activeKilocalories\":119,\"bmrKilocalories\":2283,\"steps\":3972,\"distanceInMeters\":2919.0,\"durationInSeconds\":86400,\"activeTimeInSeconds\":2786,\"startTimeInSeconds\":1634745600,\"startTimeOffsetInSeconds\":28800,\"moderateIntensityDurationInSeconds\":0,\"vigorousIntensityDurationInSeconds\":0,\"stepsGoal\":7500,\"intensityDurationGoalInSeconds\":9000,\"floorsClimbedGoal\":10}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.