using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$";
string input = @"# Valid
victor.schroeder@35up.com
victor.schroeder+foo@35up.com
v_s@35up.com
1233@35up.com
victor.schroeder@xn--bcher-kva.de
# Invalid
victor.schroeder@35up
victor.schroeder@.35up.com
victor.schroeder@35up.com.
victor.schroeder@-35up.com
victor.schroeder@35up-.com
victor.schroeder@35up.com-
victor.schroeder@35up.-com
victor.schroeder.@35up.com
victor.schroeder@35up..com
.victor.schroeder@35up.com
victor.schroeder@35--up.com
victor.schroeder@xn---bcher-kva.de
victor.schroeder@35_up.com
# Blacklisted chars
victor;schroeder@35up.com
victor,schroeder@35up.com
victor@schroeder@35up.com
victor[schroeder@35up.com
victor]schroeder@35up.com
victor(schroeder@35up.com
victor)schroeder@35up.com
victor<schroeder@35up.com
victor>schroeder@35up.com
victor:schroeder@35up.com
victor schroeder@35up.com
victor\schroeder@35up.com
victor""schroeder@35up.com";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}