$re = '/\s[-(/].*/m';
$str = 'One - two (three)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;