import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d*?(9)|\\d*?(8)|\\d*?(7)|\\d*?(6)|\\d*?(5)|\\d*?(4)|\\d*?(3)|\\d*(2)|\\d*(1))(?:\\d*(9)|\\d*(8)|\\d*(7)|\\d*(6)|\\d*(5)|\\d*(4)|\\d*(3)|\\d*(2)|\\d*(1))";
final String string = "987654321111111\n"
+ "811111111111119\n"
+ "234234234234278\n"
+ "818181911112111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}