import Foundation
let pattern = #"^(?:\d*?(9)|\d*?(8)|\d*?(7)|\d*?(6)|\d*?(5)|\d*?(4)|\d*?(3)|\d*(2)|\d*(1))(?:\d*(9)|\d*(8)|\d*(7)|\d*(6)|\d*(5)|\d*(4)|\d*(3)|\d*(2)|\d*(1))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
987654321111111
811111111111119
234234234234278
818181911112111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)