import re
regex = re.compile(r"^([pP][oO] +[bB][oO][xX]|[pP][rR][iI][vV][aA][tT][eE] +[bB][aA][gG]) +(\d+).*|^([\/\wÀ-ɏḀ-ỹ .'-]*, *)?(\d[\/\w]*)[\/\wÀ-ɏḀ-ỹ .,'#-]*$", flags=re.MULTILINE)
test_str = ("Street address:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"224B Clarence Street, Vogeltown, Wellington 6023\n\n"
"Rural address:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"128 Valley Road North, RD 2, Middlemarch 9597\n\n"
"PO Box:\n"
"¯¯¯¯¯¯¯\n"
"PO Box 17999, Greenlane, Auckland 1546\n\n"
"Street – with unit:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"3/123 Johnstone Street West, Point Chevalier, Auckland 1022\n\n"
"Rural address with unit:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"8/56 Maple Boulevard, RD 2, Wanaka 9382\n\n"
"Private Bag:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯\n"
"Private Bag 93899, Auckland 0753\n\n"
"Street – with building name:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"Level 2 Colombo House, 3A/1222 Colombo Street, St Albans, Christchurch 8014\n\n"
"Rural address – with building name:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"Totârä Farm, 2/12543 Farm Road, RD 1, Outram 9073\n\n"
"Rural address – with c/o:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"c/o James Bond, 2/12543 Farm Road, RD 1, Outram 9073\n\n"
"Other addresses around the world:\n"
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯\n"
"813 Howard Street, Oswego, NY 13126, USA\n"
"1 Beacon Street, 33rd Floor, Boston, MA 02108, USA\n"
"Hagagatan 1 vi, SE-113 49 Stockholm, Sweden\n"
"John A. Smith, ACME Innovations Inc., PO BOX 1033, Los Angeles, CA\n"
"c/o Henry Roth, 50 Oakland Ave,#206, A City, Florida, 32104, USA\n"
"10 Downing Street, London, Greater London, SW1A 2AA, United Kingdom\n"
"Av. de Senalèche 27, 1009 Pully, Switzerland\n"
"17, Rue Bergère, 75009 Paris, France\n"
"11 Bis Av. Gabriel Péri, 38150 Roussillon, France\n"
"Apostel-Paulus-Strasse 7, 10823 Berlin, Deutschland\n"
"Château Brillant, 75000 Paris, France\n\n"
"Crap data:\n"
"¯¯¯¯¯¯¯¯¯¯\n"
"$^srflkwjeras %\n"
"894\n"
"879D\n"
"7895/465\n"
"5465 D\n"
"4565 D$ wer\n"
"House name, 45\n"
"Help me please!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")