$re = '/\[([^][|]+)(?:\|([^][]+))?]/m';
$str = 'This is an example definition. Here is a link to [foo]. This is an [aliased link|bar].
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);