# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([01][0-9]|2[0-3])([0-5][0-9])\b/\1:\2/g;t' <<< "0000
2359
1200
1201
0059
0090
2459
000
3000
"