use strict;
my $str = '0000
2359
1200
1201
0059
0090
2459
000
3000
';
my $regex = qr/\b([01][0-9]|2[0-3])([0-5][0-9])\b/p;
my $subst = '\\1:\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";