$re = '/\b([01][0-9]|2[0-3])([0-5][0-9])\b/';
$str = '0000
2359
1200
1201
0059
0090
2459
000
3000
';
$subst = "\1:\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;