$re = '/.{30,}?\K\.(?=.{30,})/';
$str = 'this is a long sentence. it contains full stops. I want to match the full stop after the halfway point.
this sentence is shorter. it also contains full stops.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);