use strict;
my $str = 'Chào mừng tất cả các anh chị đến với chủ đề dinh dưỡng và các bệnh về mắt.
Chủ đề trước chúng ta đã tìm hiểu về mắt, và chúng ta đã biết rất nhiều bệnh về mắt.
(text: Chủ đề dinh dưỡng và các bệnh về mắt; font-size:87;
typetext: giới thiệu;img: mat.jpg; effect: fadein; size: 6; subtext: đôi mắt khỏe;)
Sau đây chúng ta sẽ tìm hiểu một số bệnh cơ bản về mắt mà hiện nay xã hội đang tồn tại.';
my $regex = qr/^\s*(?<text>.*?)\s*((?<format>\([^)]*\))*\s*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}