# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(?<text>.*?)\s*((?<format>\([^)]*\))*\s*)*$"
test_str = ("Chào mừng tất cả các anh chị đến với chủ đề dinh dưỡng và các bệnh về mắt.\n"
"Chủ đề trước chúng ta đã tìm hiểu về mắt, và chúng ta đã biết rất nhiều bệnh về mắt.\n"
"(text: Chủ đề dinh dưỡng và các bệnh về mắt; font-size:87; \n"
"typetext: giới thiệu;img: mat.jpg; effect: fadein; size: 6; subtext: đôi mắt khỏe;)\n\n"
"Sau đây chúng ta sẽ tìm hiểu một số bệnh cơ bản về mắt mà hiện nay xã hội đang tồn tại.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.