re = /(?i:match that)/
str = 'match this Match and that and this not working!
this match that, and this too MaTch ThAt would work for sure
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end