using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z].*)(?=.*[!@#$&*])(?=.*[a-z].*).*$";
string input = @"123q
123@
Qwe@1
Admin
admin
admin@1
Admin@";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}