re = /^(?=.*[A-Z].*)(?=.*[!@#$&*])(?=.*[a-z].*).*$/m
str = '123q
123@
Qwe@1
Admin
admin
admin@1
Admin@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end