package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?`)
var str = `Considered and decided by Hemingway, Presiding Judge; Bell,
Judge; and
Dickinson, Emily, Judge
Considered and decided by Einstein, Presiding Judge; Abel,
Judge; and
Lagrange, Gauss, Judge
Considered and decided by Newton, Presiding Judge; Dirichlet,
Judge; and
Fourier, Cauchy, Judge`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}