const regex = new RegExp('(?<=Materi.l )\\D+', 'gmi')
const str = `produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203
produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203
produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}